This article was first published on: Insights – Ripple --

Ripple has released version 1.2.2 of rippled, our reference implementation of the core XRP Ledger server.

Version 1.2.2 corrects a technical flaw in the fee escalation engine which could cause some fee metrics to be calculated incorrectly. In some circumstances this can potentially cause the server to crash.

Action Required

If you operate a XRP Ledger server, then you should upgrade to version 1.2.2 immediately.

Impact of Not Upgrading

If you operate a rippled server, but do not upgrade to 1.2.2 as soon as possible, then your server may experience restarts or outages.

Additionally, the MultisignReserve, fixTakerDryOfferRemoval and fix1578 Amendments are expected to become enabled no earlier than Wednesday, 2019-03-20. When this happens, if you are not running release 1.2.0 or greater, your server will become amendment blocked, meaning that it:

  • Cannot determine the validity of a ledger;

  • Cannot submit or process transactions;

  • Cannot participate in the consensus process;

  • Cannot v...

This content is synced from the rightful owners. Copyright on text and images belong to the original source. -- This article was first published on: Insights – Ripple